Upgrade Information

This section contains essential information related to upgrading an existing Prognosis installation to the latest version. These notes should be reviewed before proceeding with the upgrade.

In some scenarios, there may be additional upgrade steps required before or after performing the Prognosis upgrade, in particular, if Prognosis is monitoring the following systems or running these applications, then read the associated upgrade pages:

License Requirement

When upgrading from Prognosis 11.x to Prognosis 11.7, in most cases, no new license will be required. However, for upgrades from Prognosis 10.x a new Prognosis license will need to be obtained, please contact your nearest IR sales office for details.

Shut down on Upgrade

Prognosis will shut down for the upgrade. Therefore, users who are using the Web Application will be logged out during this time. Users need to re-login to the Web Application after completion of the upgrade.

Important Upgrade Notes 

  • Prognosis 11.7 will not be able to connect to or manage versions older than Prognosis 11.0. When an upgrade is to be phased in across several servers, it will be necessary to upgrade all servers to an intermediate version first, for example, 11.0, and then move each to Prognosis 11.7 to retain visibility into all the servers. Refer to Connectivity for further information.
  • The previous Prognosis installation directory cannot be preserved if it is under ‘Program Files’ or ‘Program Files (x86)’. The default directory for the upgrade is the ‘Prognosis’ folder immediately under the root folder of the system drive.
  • Important changes were made to the way that Prognosis handles encryption for passwords and server-to-server communication in Prognosis 11.0. This latest Prognosis version is similar. Please be mindful of this extra security feature that has been put in place when planning an upgrade to Prognosis 11.7 from versions before Prognosis 11.0.   
  • Custom dashboards that were created using both .dpy and .dashboard files with Prognosis version 10.4 or earlier may not work after upgrade to Prognosis 11.7. Additional META.INTERVAL information is needed to handle time zones on these Displays. This will most likely require some adjustments and then redeployment to the web after the upgrade. 
  • Upgrading to Prognosis 11.7 from an earlier version of Prognosis may fail when custom databases are running with a name of more than 24 characters. These databases need to be stopped before attempting the upgrade. This is only applicable to the custom database as part of a consulting solution or custom database started by the end users, which may have names longer than 24 characters.  
  • Upgrading to Prognosis 11.7 from an earlier version of Prognosis may fail due to the lack of necessary permissions. The resolution is to run or execute the Prognosis 11.7 Installer with the “Run as administrator” option.  

Then, before starting the upgrade please pay particular attention to the following topics:

Provide feedback on this article