Help Center

Exporting Display Data to Excel

By exporting data to MS Excel, you can use the various tools in this product to analyze the information or use the formatting features to customize the appearance of the report.

The report can also be converted to HTML to be published on a company Intranet or Internet. There are many tools to convert to HTML, however there is a Save as HTML command on the File menu.

Two methods are available to export data from a Display to Excel. These are based upon the amount of data required and the Run Mode type of the Display.

Excel worksheets cannot have the following characters in the worksheet name:  : / \ ?  these characters will be replaced with a space.

Send to Excel Option (Run Mode - 'Report')

This method applies only to Displays that have the Run Mode set to 'Report'. When the 'Send to Excel' option is set on the Reports tab, data will be automatically sent to Excel when the Display is run.

The complete range of data from a linked Database Collection or Summary will be exported to Excel. The whole database will be sent unless a specific period is set on the Database tab.

Open the Display properties dialog box of the required Display.

On the Windows tab, select the Report Run Mode.

Proceed to the Database tab and enter the required Database details.

Go to the Report tab and select the Send to Excel check box.

In the Display Windows field select the data windows that are to be sent to Excel.

When finished select OK, this will save the document as a Report Display, indicated by the  icon.

To create the Excel document, run the Report Display. The Display will open in the workspace and Excel will be started. An Excel workbook will be created for each Window in the Display with each named as the Display window name.

You can apply formatting to the worksheet if required, such as a Heading at the top with the Company name, the Report name and the date. You can use the Format menu, Autoformat feature to quickly apply some formatting.

When finished save your Excel spreadsheet.

Be careful with this option as you may create a very large Excel document.

Direct Export to Excel (All Run Modes)

This method applies to all 'Run Mode' types and utilizes the  toolbar icon, or the context menu option of 'Send to Excel' which is available when right-clicking over a Display. Depending on the Run Mode type, various data is sent to Excel:

Online - the real-time data shown on screen at any instance will be exported to Excel.

Replay - the data shown on screen from a linked Database replay will be sent to Excel. The data displayed on screen at any time can be controlled through the Display Control toolbar.

Report - the complete range of data from a linked Database Collection or Summary will be exported to Excel. The whole database will be sent unless a specific period is set on the Database tab.

Using the Toolbar Button

With the required Display open in your workspace, click the  icon on the toolbar. This will automatically open Excel and export the data.

In this case, a single Excel workbook will be created containing an individual worksheet for each window of the Display.

Using the Context Menu

By right-clicking your mouse over a Display window, then selecting 'Send to Excel' from the context menu, the data from only that window will be sent to Excel.

In either case, once your Spreadsheet has been created you can then apply formatting to the worksheet if required, such as a Heading at the top with the Company name, the Report name and the date. You can use the Format menu, Auto format feature to quickly apply some formatting.

When finished save your Excel spreadsheet.

Provide feedback on this article